Среда, 13.12.2017, 15:51
Главная Регистрация RSS
Приветствую Вас, Гость
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 1 из 11
Форум » Основной » Проблемные ситуации » Конструктор запросов ИР. Ошибка при выборе полей
Конструктор запросов ИР. Ошибка при выборе полей
JohnyDДата: Понедельник, 10.07.2017, 18:01 | Сообщение # 1
Сержант
Группа: Проверенные
Сообщений: 24
Репутация: 4
Статус: Оффлайн
Есть запрос:


Код
ВЫБРАТЬ
   КонтрагентыТ.Ссылка КАК Ссылка,
   КонтрагентыТ.КПП КАК КПП
ПОМЕСТИТЬ втКонтрагенты
ИЗ
   Справочник.Контрагенты КАК КонтрагентыТ


Открываем его в Конструкторе ИР.
Жмакаем на вкладку "Выбор полей"
Переходим обратно на вкладку "Выбор таблиц" (ничего не меняя)
И теперь обратно на "Выбор полей". Вываливается ошибка:


Цитата
{ВнешняяОбработка.ирКлсПолеТекстовогоДокументаСКонтекстнойПодсказкой.Форма.КонструкторЗапроса.Форма(3487)}: Ошибка при вызове метода контекста (НайтиПоле)
ДоступноеПолеУсловия = КомпоновщикЧасти.Настройки.ДоступныеПоляОтбора.НайтиПоле(ТекущееДоступноеПолеУсловия);
по причине:
Несоответствие типов (параметр номер '1')

Информация для ТП:

Цитата
ОС: Windows x86 Microsoft Windows 8.1 version 6.3  (Build 9600)
Платформа: 8.3.10.2299
Конфигурация: 1С:ERP Управление предприятием 2 (2.2.2.73)
Режим БД: клиент-серверный
Приложение: Обычное приложение 32б
От имени администратора Windows: Нет
Режим совместимости: НеИспользовать
Инструменты разработчика: Портативные 4.16p
 
tormozit1Дата: Понедельник, 10.07.2017, 19:51 | Сообщение # 2
Лейтенант
Группа: Администраторы
Сообщений: 62
Репутация: 5
Статус: Оффлайн
Спасибо. Ошибку воспроизвел. Замечу, что она не препятствует работе, но конечно раздражает. Обойти ее можно активизировав любую строку в списке доступных полей.

Исправить ее самостоятельно можно заменив код в конце метода ОбновитьКомпоновщикЧастиОбъединения на
Код
// Восстановим текущие доступные поля
    Если ТекущееДоступноеПолеВыбора <> Неопределено Тогда
        Если ТекущееДоступноеПолеВыбора <> Неопределено Тогда
            ДоступноеПолеВыбора = КомпоновщикЧасти.Настройки.ДоступныеПоляВыбора.НайтиПоле(ТекущееДоступноеПолеВыбора);
            Если ДоступноеПолеВыбора <> Неопределено Тогда
                ЭлементыФормы.ДоступныеПоляВыбора.ТекущаяСтрока = ДоступноеПолеВыбора;
            КонецЕсли;
        КонецЕсли;
        Если ТекущееДоступноеПолеУсловия <> Неопределено Тогда
            ДоступноеПолеУсловия = КомпоновщикЧасти.Настройки.ДоступныеПоляОтбора.НайтиПоле(ТекущееДоступноеПолеУсловия);
            Если ДоступноеПолеУсловия <> Неопределено Тогда
                ЭлементыФормы.ДоступныеПоляУсловия.ТекущаяСтрока = ДоступноеПолеУсловия;
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
    Возврат ИсточникНастроек;
 
tormozit1Дата: Понедельник, 17.07.2017, 00:48 | Сообщение # 3
Лейтенант
Группа: Администраторы
Сообщений: 62
Репутация: 5
Статус: Оффлайн
Исправлено в 4.17
 
Форум » Основной » Проблемные ситуации » Конструктор запросов ИР. Ошибка при выборе полей
Страница 1 из 11
Поиск: