Понедельник, 24.09.2018, 08:34
Главная Регистрация RSS
Приветствую Вас, Гость
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 1
  • 1
Форум » Основной » Проблемные ситуации » Ошибка при создании нового запроса в Консоли запросов
Ошибка при создании нового запроса в Консоли запросов
BabysДата: Среда, 16.05.2018, 16:16 | Сообщение # 1
Рядовой
Группа: Пользователи
Сообщений: 11
Репутация: 6
Статус: Оффлайн
Списке запросов нажимаю добавить, и ...

Цитата
{ВнешняяОбработка.ирОбщий.МодульОбъекта(13247)}: Получение элемента по индексу для значения не определено
        БазовоеИмя = БазовоеИмяИлиСтрока[ИмяКлючевойКолонки];


Что бы не ванговать

Цитата
Платформа: 8.3.6.2152
Режим БД: клиент-серверный
Конфигурация. Название: Зарплата и управление персоналом КОРП, редакция 2.5 (2.5.130.2)
Конфигурация. Основной режим запуска: Обычное приложение
Конфигурация. Режим совместимости: Версия8_2_13
Инструменты разработчика: Портативные 4.53p
Клиент. ОС: Windows x86 version 6.1 Service Pack 1 (Build 7601)
Клиент. Приложение: Обычное приложение 32б
Клиент. От имени администратора Windows: Нет
Сервер. ОС: Windows x86 version 6.1 Service Pack 1 (Build 7601)
Сервер. Отладка: нет
 
tormozitДата: Среда, 16.05.2018, 21:18 | Сообщение # 2
Генералиссимус
Группа: Администраторы
Сообщений: 2051
Репутация: 26
Статус: Оффлайн
Спасибо. Ошибку воспроизвел.
Замечу, что она не препятствует выполнению запрошенного пользователем действия.
Исправить ее самостоятельно можно исправлением функции ирОбщий.ПолучитьАвтоУникальноеИмяВКоллекцииСтрокЛкс
Код
Функция ПолучитьАвтоУникальноеИмяВКоллекцииСтрокЛкс(КоллекцияСтрок, БазовоеИмяИлиСтрока, ИмяКлючевойКолонки = "Имя", ИмяДолжноБытьИдентификатором = Истина,
    ЗаменаПустойСтроки = "_", Знач ДопустимаяДлинаИдентификатораЕслиНеЗаданаВКолонке = 50) Экспорт
    
    ТекущийИндекс = 0;
    Если ТипЗнч(БазовоеИмяИлиСтрока) = Тип("Строка") Или БазовоеИмяИлиСтрока = Неопределено Тогда
        БазовоеИмя = БазовоеИмяИлиСтрока;
    Иначе
        ИсключаемаяСтрока = БазовоеИмяИлиСтрока;
        БазовоеИмя = БазовоеИмяИлиСтрока[ИмяКлючевойКолонки];
        //ТекущийИндекс = 1;
    КонецЕсли;
    Если ТипЗнч(КоллекцияСтрок) = Тип("ТаблицаЗначений") Тогда
        Колонки = КоллекцияСтрок.Колонки;
    ИначеЕсли ТипЗнч(КоллекцияСтрок) = Тип("КоллекцияСтрокДереваЗначений") Тогда
        Если КоллекцияСтрок.Количество() > 0 Тогда
            Колонки = КоллекцияСтрок[0].Владелец().Колонки;
        КонецЕсли;
    Иначе // Табличная часть
        Колонки = КоллекцияСтрок.ВыгрузитьКолонки().Колонки;
    КонецЕсли;
 
tormozitДата: Воскресенье, 20.05.2018, 20:50 | Сообщение # 3
Генералиссимус
Группа: Администраторы
Сообщений: 2051
Репутация: 26
Статус: Оффлайн
Исправлено в 4.54
 
Форум » Основной » Проблемные ситуации » Ошибка при создании нового запроса в Консоли запросов
  • Страница 1 из 1
  • 1
Поиск: