Среда, 26.09.2018, 14:06
Главная Регистрация RSS
Приветствую Вас, Гость
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 1
  • 1
Форум » Основной » Проблемные ситуации » Консоль запросов. Ошибка открытия конструктора запроса ИР
Консоль запросов. Ошибка открытия конструктора запроса ИР
BabysДата: Среда, 16.05.2018, 09:10 | Сообщение # 1
Рядовой
Группа: Пользователи
Сообщений: 11
Репутация: 6
Статус: Оффлайн
Запрос СКД из типовой:

Код
см. аттач

Пытаюсь открыть его КонструкторИР, получаю:

Цитата
{ВнешняяОбработка.ирОбщий.МодульОбъекта(13259)}: Получение элемента по индексу для значения не определено
ДопустимаяДлинаИдентификатора = Колонки[ИмяКлючевойКолонки].ТипЗначения.КвалификаторыСтроки.Длина;

Ну и собственно:

Код
Платформа: 8.3.6.2152
Режим БД: клиент-серверный
Конфигурация. Название: Зарплата и управление персоналом КОРП, редакция 2.5 (2.5.130.2)
Конфигурация. Основной режим запуска: Обычное приложение
Конфигурация. Режим совместимости: Версия8_2_13
Инструменты разработчика: Портативные 4.53p
Клиент. ОС: Windows x86 version 6.1 Service Pack 1 (Build 7601)
Клиент. Приложение: Обычное приложение 32б
Клиент. От имени администратора Windows: Нет
Сервер. ОС: Windows x86 version 6.1 Service Pack 1 (Build 7601)
Сервер. Отладка: нет
в 4.52 тоже самое

Добавлено (16.05.2018, 09:10)
---------------------------------------------
И сюда же наверно. Попробуй построить Дерево запроса.У меня оно состоит из 1 подзапроса :

Код
РегистрСведений.РаботникиОрганизаций.СрезПоследних(&Период {(&Период)}, {(Сотрудник), (Сотрудник.Физлицо) КАК ФизЛицо, (Организация) КАК ГоловнаяОрганизация};)
Прикрепления: 0703047.sel(181.6 Kb)
 
tormozitДата: Среда, 16.05.2018, 21:15 | Сообщение # 2
Генералиссимус
Группа: Администраторы
Сообщений: 2055
Репутация: 26
Статус: Оффлайн
Спасибо. Ошибку воспроизвел.
Исправить ее самостоятельно можно исправлением функции ирОбщий.ПолучитьАвтоУникальноеИмяВКоллекцииСтрокЛкс

Код
Функция ПолучитьАвтоУникальноеИмяВКоллекцииСтрокЛкс(КоллекцияСтрок, БазовоеИмяИлиСтрока, ИмяКлючевойКолонки = "Имя", ИмяДолжноБытьИдентификатором = Истина,
    ЗаменаПустойСтроки = "_", Знач ДопустимаяДлинаИдентификатораЕслиНеЗаданаВКолонке = 50) Экспорт
    
    ТекущийИндекс = 0;
    Если ТипЗнч(БазовоеИмяИлиСтрока) = Тип("Строка") Или БазовоеИмяИлиСтрока = Неопределено Тогда
        БазовоеИмя = БазовоеИмяИлиСтрока;
    Иначе
        ИсключаемаяСтрока = БазовоеИмяИлиСтрока;
        БазовоеИмя = БазовоеИмяИлиСтрока[ИмяКлючевойКолонки];
        //ТекущийИндекс = 1;
    КонецЕсли;
    Если ТипЗнч(КоллекцияСтрок) = Тип("ТаблицаЗначений") Тогда
        Колонки = КоллекцияСтрок.Колонки;
    ИначеЕсли ТипЗнч(КоллекцияСтрок) = Тип("КоллекцияСтрокДереваЗначений") Тогда
        Если КоллекцияСтрок.Количество() > 0 Тогда
            Колонки = КоллекцияСтрок[0].Владелец().Колонки;
        КонецЕсли;
    Иначе // Табличная часть
        Колонки = КоллекцияСтрок.ВыгрузитьКолонки().Колонки;
    КонецЕсли;
    Если ИмяДолжноБытьИдентификатором Тогда
...
 
tormozitДата: Среда, 16.05.2018, 21:22 | Сообщение # 3
Генералиссимус
Группа: Администраторы
Сообщений: 2055
Репутация: 26
Статус: Оффлайн
По второй проблеме это нормально. Дерево запроса строится только по основному тексту запроса, а расширения языка запросов оно не анализирует. Отчасти поэтому дерево строится заметно быстрее, чем загрузка запроса в конструктор.
 
BabysДата: Четверг, 17.05.2018, 08:37 | Сообщение # 4
Рядовой
Группа: Пользователи
Сообщений: 11
Репутация: 6
Статус: Оффлайн
Цитата tormozit ()
Дерево запроса строится только по основному тексту запроса, а расширения языка запросов оно не анализирует.
Спасибо за уточнение, я не знал.
 
tormozitДата: Воскресенье, 20.05.2018, 20:50 | Сообщение # 5
Генералиссимус
Группа: Администраторы
Сообщений: 2055
Репутация: 26
Статус: Оффлайн
Исправлено в 4.54
 
Форум » Основной » Проблемные ситуации » Консоль запросов. Ошибка открытия конструктора запроса ИР
  • Страница 1 из 1
  • 1
Поиск: