Воскресенье, 22.07.2018, 13:15
Главная Регистрация RSS
Приветствую Вас, Гость
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
  • Страница 1 из 1
  • 1
Форум » Основной » Проблемные ситуации » КонсольЗапросовИР (Удалить переносы строк(|), заменить парные двойные кавы...)
КонсольЗапросовИР
gslawaДата: Среда, 14.02.2018, 15:47 | Сообщение # 1
Лейтенант
Группа: Проверенные
Сообщений: 41
Репутация: 18
Статус: Оффлайн
Код
Платформа: 8.3.11.3034
Режим БД: файловый
Конфигурация: Управление торговлей. (10.3.21.2)
Основной режим запуска: Обычное приложение
Режим совместимости: Версия8_2_13
Инструменты разработчика: Портативные 4.40p
Клиент. ОС: Windows x86 version 6.2  (Build 9200)
Клиент. Приложение: Обычное приложение 32б
Клиент. От имени администратора Windows: Нет


В КонсольЗапросовИР копируем
Код
"ВЫБРАТЬ
|   Номенклатура.Ссылка
|ИЗ
|   Справочник.Номенклатура КАК Номенклатура";

Нажимаем: Удалить переносы строк(|), заменить парные двойные кавычки на одинарные, удалить граничные кавычки

Получаем:

Код
ВЫБРАТЬ
   Номенклатура.Ссылка
ИЗ
   Справочник.Номенклатура КАК Номенклатур

Удалился последний символ псевдонима Номенклатура
 
tormozitДата: Среда, 14.02.2018, 22:18 | Сообщение # 2
Генералиссимус
Группа: Администраторы
Сообщений: 1988
Репутация: 26
Статус: Онлайн
Спасибо. Ошибку воспроизвел.

Исправить ее самостоятельно можно заменой в модуле ирКлсПолеТекстовогоДокументаСКонтекстнойПодсказкой процедуры

Код
Процедура УдалитьПереносы()

    Если Ложь
        Или ПолеТекстовогоДокумента.ТолькоПросмотр
        Или ФормаВладелец.ТолькоПросмотр
    Тогда
        Возврат;
    КонецЕсли;
    Текст = ПолеТекстовогоДокумента.ПолучитьТекст();
    Текст = СокрЛП(Текст);
    Если Истина
        И Лев(Текст, 1) = """"
        И Лев(Текст, 2) <> """"""
    Тогда
        Текст = Сред(Текст, 2);
    КонецЕсли;
    Если Истина
        И Прав(Текст, 1) = """"
        И Прав(Текст, 2) <> """"""
    Тогда
        Текст = Лев(Текст, СтрДлина(Текст) - 1);
    КонецЕсли;
    Если Истина
        И Прав(Текст, 2) = """;"
        И Прав(Текст, 3) <> """"";"
    Тогда
        Текст = Лев(Текст, СтрДлина(Текст) - 2);
    КонецЕсли;
    Текст = СтрЗаменить(Текст, "|", "");
    Текст = СтрЗаменить(Текст, """""", """");
    ПолеТекстовогоДокумента.УстановитьТекст(Текст);
    УстановитьПризнакМодифицированностиФормы();
    
КонецПроцедуры // УдалитьПереносы()
 
tormozitДата: Воскресенье, 25.02.2018, 13:20 | Сообщение # 3
Генералиссимус
Группа: Администраторы
Сообщений: 1988
Репутация: 26
Статус: Онлайн
Исправлено в 4.41
 
Форум » Основной » Проблемные ситуации » КонсольЗапросовИР (Удалить переносы строк(|), заменить парные двойные кавы...)
  • Страница 1 из 1
  • 1
Поиск: